FUNDAMENTOS DE INFORMÁTICA Y PROGRAMACIÓN PARA INGENIERÍA
Ejercicios resueltos para C y Matlab


M. Castrillón, A. C. Domínguez. S. Candela. L. Doreste
D. Freire, A. Salgado, S. L. Khemchandani, D. Hernández
Ediciones Paraninfo, 2011
Modesto

Ficha
El libro está pensado para que el estudiante adquiera los conceptos fundamentales de la informática, así como las capacidades de análisis, diseńo e implementación de programación de una manera amena, directa y sobre todo práctica. Para ello utiliza dos de los lenguajes más utilizados en los distintos campos de las ingenierías como son el lenguaje C y Matlab. El libro presenta más de 150 ejercicios de fundamentos de informática con las correspondientes soluciones y más de 150 ejercicios resueltos de programación que permiten el auto aprendizaje.

Transparencias/Diapositivas
Fundamentos de informática Fundamentos de programación

Erratas
Erratas detectadas

  • Ejercicio 45 página 242, solución algorítmica
  • prod=0
    para i desde 1 hasta abs(y) hacer
    prod=prod+x
    fin para
    si y<0 entonces
    Escribir("El resultado es: ", -prod)
    si no
    Escribir("El resultado es: ", prod)
    fin si
  • Ejercicio 54 página 254, solución algorítmica
  • ...
    fin mientras
    si cont == 0 entonces
    Escribir("Es un número primo")
    fin si
    fin Algoritmo
  • Ejercicio 95 página 313, solución algorítmica
  • ...
    para i desde 1 hasta n hacer
    Escribir("Introduzca los elementos del vector A[i]")
    Leer(A[i])
    comprobado[i]=falso
    fin para
    para i desde 1 hasta n hacer
    enc = 0
    para j desde i+1 hasta n hacer
            si A[i] == A[j] Y comprobado[i]==falso entonces

                enc = enc + 1

                comprobado[j]=verdadero

            fin si

    fin para
    si enc <> 0 entonces
            Escribir("El elemento  ", A[i], " se repite ", enc+1, "veces.")

    fin si
    fin para
    ...
  • Ejercicio 97 página 318, solución algorítmica
  • ...
    mientras ordenado==verdadero Y i < n hacer
    si v[i]>v[i+1] entonces
                ordenado=falso

    fin si
    i=i+1
    fin mientras
    ...
  • Ejercicio 97 página 319, solución Matlab
  • ...
    while asc==1 && i < n
    if v[i]>v[i+1]
                asc=0;

    end
    i=i+1;
    end
    ...
  • Ejercicio 106 página 338, solución algorítmica
  • mientras fila <= n hacer
  • Ejercicio 107 página 340, solución algorítmica
  • mientras columna <= n hacer
  • Ejercicio 121 página 359, solución algorítmica
  • si Posición(cad[i],consonantes) entonces
  • Ejercicio 123 página 362, solución algorítmica
  • j = j mod Longitud(abc)
  • Ejercicio 123 página 363, solución Matlab
  • j = j - 'Z' + 'A' - 1;
  • Ejercicio 127 página 370, solución Matlab
  • num = num+( double( upper(cad(i)) )-double('A')+1);
  • Ejercicio 124 página 364, solución algorítmica
  • para j desde 1 hasta ast[i] hacer
  • Ejercicio 138 página 39~1, solución Matlab
  • while ~feof(f)
    ...
    fclose(f)
Formulario de comunicación de erratas detectadas en el libro